Mikrotik wake on lan: Как удаленно включить компьютеры с помощью функции Wake-on-LAN в Mikrotik Routerboard — asp24.ru

Содержание

Как удаленно включить компьютеры с помощью функции Wake-on-LAN в Mikrotik Routerboard — asp24.ru

 

Функция Wake-on-LAN позволяет удалённо включать компьютер, отправляя пакет данных, созданный специальным образом. Этот пакет еще называют «волшебным пакетом».

В Mikrotik Routerboard также есть возможность использовать данную технологию. Получить доступ к функции Wake-on-LAN в Mikrotik Routerboard мы можем в разделе Tool.

 

 

Рис.1. Mikrotik Routerboard Winbox, Tools.

 

Но если воспользоваться Winbox, то в разделе Tools необходимый пункт меню мы не увидим.

 

 

Рис.2. Mikrotik Routerboard New Terminal.

 

А вот если воспользоваться возможностями New Terminal, то мы без проблем найдем необходимую функцию.

 

 

Рис.3. Команда wol.

 

Пишем команду. Структура команды следующая:

Переход в раздел Tool:

tool

Функция Wake-on-LAN в  Mikrotik Routerboard:

wol

Интерфейс, через который будет посылаться пакет:

interface=ether1

MAC-адрес компьютера, который хотим разбудить:

mac=FF:FF:FF:FF:FF:FF

Можно настроить Mikrotik Routerboard таким образом, чтобы он в определенное время включал нужные компьютеры. Сделать это легко, воспользовавшись возможностями написания скриптов и планировщиком в Mikrotik Routerboard.

 

 

Рис.4.  Mikrotik Routerboard Scheduler.

 

 

Рис.5.  Mikrotik Routerboard Scheduler script.

 

Приятное начало рабочего дня: мы только пришли на работу, а компьютеры уже запущены и ждут.

 

 

:local a; :put [:typeof $a];

 

Евгений Рудченко специально для ASP24.

 

Удалённое включение компьютера бесплатно, без SMS и без облаков, с помощью Mikrotik

… а также без проброса портов, SSH/telnet и установки сторонних приложений. С любого компьютера, подключённого к интернет и даже с телефона!

Периодически мне бывает нужно включить домашний компьютер, когда я нахожусь не дома. Обычно я не запаривался и звонил или отправлял сообщение с такой просьбой жене, которая сидит дома в декрете.

Очень удобное средство удалённого управления с голосовым интерфейсом. Однако у этого способа есть ряд недостатков — ушла гулять, укладывает ребёнка, или ещё чем либо занята. Хотелось простого решения из того что есть под рукой.

Первым делом включаем Wake on LAN в BIOS’е материнской платы, у всех это делается по-своему, у многих включено по умолчанию. На одном из моих ПК даже такой опции нету — всегда включено.

Далее переходим в WinBox и подключаемся к вашему роутеру (если хотите, можете через SSH или через HTTP(S), я всё делаю в WinBox’е). Если открыть текстовую консоль RouterOS и пошарить там в разделе /tool (или в wiki-мануалах), то можно обнаружить утилиту wol со следующим синтаксисом:

/tool wol mac=XX:XX:XX:XX:XX:XX interface=ifname

Где ifname — имя интерфейса, с которого будет рассылаться волшебный пакет, XX:XX:XX:XX:XX:XX — mac адрес вашего компьютера.

Вроде всё просто, но Winbox с телефона не особо запускается и mac адрес по памяти замучаешься вводить. Можно запускать SSH и отправлять в него одну единственную команду, но это тоже долго и нудно. Используем фаервол!

Напрямую из правил фильтра запускать исполнение команд нельзя, из всех действий нам больше всех подойдёт добавление адреса в address-list, т.к. оно позволяет создать новый объект в операционной системе роутера, доступный из скриптов.

Добавим новое правило для цепочки input и расположим его среди других разрешающих правил этой цепочки. Укажем протокол tcp и dst-port — любой из верхних портов.

Действие выберем add src (можно и dst) to address list, укажем имя листа.

Для отслеживания появления записей используем планировщик. Заходим System -> Sheduler, создаём задание планировщика, задаём имя. Указываем Start time: startup, и желаемый интервал, к примеру каждые 15 секунд.

В поле on event напишем простенький скрипт:

:local WAKEPC [/ip firewall address-list find where list="WAKEPC"]
:if ($WAKEPC!="") do={
/tool wol mac=00:11:22:33:44:55 interface=bridge_lan
/ip firewall address-list remove [find where list="WAKEPC"]
}

Не забываем указать правильный mac, имя интерфейса и адрес-листа. Данный скрипт при обнаружении элементов в адрес-листе выполнит команду, отправляющую магические пакеты на ваш компьютер, после чего удалит запись из адрес-листа.

Для включения вашего компьютера достаточно открыть браузер и перейти на IP вашего микротика, указав порт, который мы задали в правиле фаервола: http://your.router.net:port, после чего фаервол создаёт запись в адрес-листе, задание планировщика обнаружит эту запись, выполнит запуск утилиты wol, и удалит запись из адрес-листа. Проще паренной репы, можем добавить адрес в избранное, чтобы каждый раз не вводить.

Только не забывайте про безопасность, данный способ ничем не защищён и кто угодно может включить Ваш компьютер, зная или подобрав нужный порт. Для защиты можно использовать VPN, port knocking, whitelist или метод Неуловимого Джо — решать Вам. Если Вам требуется включать таким образом по-отдельности несколько компьютеров, создайте соответствующее количество правил на разных портах, каждое из которых будет кидать адреса в свой адрес-лист, скрипт в задании планировщика также размножаем через Ctrl+C, Ctrl+V, либо создаём отдельные задания для каждого — как хотите.

Удалённое включение компьютера бесплатно, без SMS и без облаков, с помощью Mikrotik. Включить компьютер удаленно: способы

Технология удаленного включения (Wake on LAN) должна быть поддерживаемой BIOS и сетевой картой. Также, нам понадобится специальное приложение, функции которого позволяют отправить WOL-пакет удаленному ПК.

Благодаря современным достижениям, удаленный ПК включить можно не только с иного компьютера, но и с телефона. Также необходимо помнить, что включение компьютера в удаленном режиме предполагает активность сетевой карты — она должна получать питание в дежурном режиме.

Подготовительные действия

Первым делом, нужно настроить BIOS и сетевой адаптер на пробуждение. Неважно, какая это сетевая — встроенная или внешняя. Открыв главную программу ввода-вывода, найдем секцию, отвечающую за управление питанием — Power Management, например.

В этой секции надо найти параметры пробуждения.

Эти параметры могут носить различные названия, включая Wake on LAN, PowerOn By PCI Card, WOL from Soft-Off и прочее. Надо, чтобы данная опция была включена.

Вполне возможно, что понадобится включить и опцию на картинке ниже.

Для большей уверенности лучше ознакомиться со всеми параметрами пробуждения вашего BIOS. Ведь компьютер может просыпаться и от ТВ-тюнера, если задействована опция включения по PCI-Express, и после нажатия любой клавиши на клавиатуре, если задействованы опции связанные с PS/2-портом. В нашем случае нужен параметр, связанный с PCI-шиной, на которой размещен контроллер встроенной сетевой.

Настроив BIOS, обязательно проверьте, поддерживается ли обсуждаемая технология вашим Ethernet-контроллером. Нам понадобится включить прием «магического» WOL-пакета, чтобы Ethernet-контроллер был настроен на его ожидание. WOL-пакет — это специальный Ethernet-кадр, состоящий из последовательности байт, содержащих MAC-адрес сетевой карты. Получив такой фрейм, Ethernet-карта генерирует сигнал на пробуждение ПК.

Итак, откроем центр управления сетями.

Откроем свойства сетевого адаптера.

Перейдем к его настройкам.

Включим WOL Пакет Magic и при необходимости включим Energy Efficiant Ethernet, Завершение Пробуждение.

Перейдем на вкладку управления электропитанием, где должна быть такая конфигурация.

WakeMeOnLan

Воспользуемся для наших целей небольшой программкой Wakmeonlan. Это приложение не нуждается в инсталляции. После его старта надо просканировать локальную сеть, чтобы Wakemeonlan нашла все сетевые устройства.

Работать она должна на ПК, с которого будет генерироваться WOL-фрейм для включения удаленного ПК. Так Wakemeonlan проводит сканирование:

Если в ходе сканирования приложение не обнаружило отключенный на данный момент компьютер, тогда есть возможность самостоятельного его добавления.

Добавим еще одно устройство вручную.

Нужно лишь внести в форму IP-адрес этого устройства и его MAC.

Определим нужные нам адреса, для чего запустим командную строку.

Выполним ipconfig с ключом /all.

Второй способ — заглянем в «Состояние адаптера».

Откроем окно Сведения.

Найдем интересующие нас адреса.

Добавив нужное устройство, обновим список.

Как видим, у нас уже три устройства.

После добавления, вы легко можете включить его в удаленном режиме, нажав кнопочку «Wake up Selected Computer».

Воспользуемся TeamViewer

Выполненная предварительная настройка позволит запустить функцию Wake on LAN такого приложения как TeamViewer. Чтобы удаленно разбудить ПК, необходимо обеспечить следующее:

Кабельное подключение к интернету.

Компьютер переведен в один из режимов: гибернация, сон или мягкое выключение (Пуск и Завершение работы).

Установленный TeamViewer.

Очень важно выключить быстрый запуск в таких операционках, как Windows 8 и 10. Ваши экземпляры TeamViewer должны быть связаны с учетной записью программы. При этом все устройства должны принадлежать одной LAN.

Во вкладке опции приложения нужно активировать функцию Wake-on-LAN и настроить конфигурацию, кликнув одноименную кнопочку. Выбрав опцию «Другие приложения в той же локальной сети», добавьте TeamViewer ID тех устройств, с которых разрешено пробуждать данный компьютер. Для создания условий включения по публичному IP-адресу придется подсоединяться с динамическим DNS, который также придется настраивать на роутере сети. Рассмотрим все шаги по порядку.

Прежде всего, свяжем все компьютеры с существующим аккаунтом.

Окно предупреждения о необходимости связи с аккаунтом.

Привязка с помощью кнопочки «Связать».

В нижней части отображается установленная связь.

Нам понадобится сконфигурировать функцию Wake on Lan.

Устанавливаем флажок у других приложений TeamViewer.

Добавляем ID TeamViewer-а, компьютер которого будет отсылать WOL-пакет.

Разбудить удаленный ПК можно из своей учетной записи TeamViewer, где отображаются все привязанные к ней устройства. Нужно лишь нажать кнопочку в виде кнопки питания, что приведет к отсылке WOL-фрейма на Ethernet-карту избранного электронного устройства.

Краткий итог

Чтобы удаленно включать ПК из другого устройства, надо настроить BIOS и Ethernet-карту. В BIOS понадобится настроить политику пробуждения ПК по сигналу сетевой, которая находится в активном состоянии, обеспечиваемая дежурным питанием. Также, нужно настроить Ethernet-контроллер на прием WOL-пакетов. Понадобится еще специальная программа для генерирования WOL-пакета. Такой программой может быть, например, Wakemeonlan или TeamViewer.

А Вы знали, что компьютер можно включить удалённо через lan сеть или даже через интернет. Технология Wake-On-LAN существует уже довольно давно, и сейчас мы рассмотрим, как она работает.

Wake-On-LAN (иногда сокращенно WoL) является стандартным протоколом для пробуждения компьютеров дистанционно. Естественно компьютер должен быть подключен физически и к электричеству и к роутеру с помощью проводного или даже по Wi-Fi соединения. Протокол Wake-on-Wireless-LAN позволяет включить компьютер и без проводного сетевого соединения.

Включение Wake-On-LAN зависит от двух вещей: материнской платы и сетевой карты. Ваша материнская плата должна быть подключена к ATX-совместимому блоку питания, т.е. практически к любому блоку питания, который выпускается уже лет 17 как. Сетевая карта или беспроводная карта также должны поддерживать эту функцию. Поскольку включение протокола WoL устанавливается либо через BIOS, либо через прошивку Вашей сетевой карты. В последнем случае понадобится специальное программное обеспечение, чтобы включать компьютер.

Поддержка Wake-On-LAN является довольно обычной возможностью встраиваемой в материнские и сетевые карты по умолчанию. Причём среди перечисленных характеристик в магазинах уже и не встретишь упоминания о поддержке Wake-On-LAN.

Magic Packet: Как работает Wake-on-LAN

Wake-On-LAN включает компьютер, посылая на его сетевую карту «волшебные пакеты», которые включают в себя сетевой широковещательный адрес, широковещательный адрес, MAC-адрес сетевой карты, и специальную последовательность байтов — пакет данных. Эти магические пакеты абсолютно идентичные для любой платформы будь то Intel или AMD или Apple. Типичные порты, используемые для WoL и магических пакетов — UDP 7 и 9. Поскольку каждый компьютер активно прослушивает канал передачи данных, то такой волшебный пакет, имеющий в себе уникальный идентификатор компьютера (MAC-адрес сетевой карты), без труда будет пойман и обработан.

На рисунке выше показаны результаты анализатора пакетов. Здесь возникает резонный вопрос: а безопасна ли передача волшебного пакета? Ведь перехватить незащищённый трафик не составит труда. На сколько безопасна передача Wake-On-LAN при использовании в небезопасных сетях и через Интернет? В защищенной сети или при домашнем использовании не должно быть повода для беспокойства. А в открытой сети, лучше не использовать Wake-On-LAN или по меньше мере заботиться о профиле соединения вашей сетевой карты, выбирая хотя бы варианты с минимальной открытостью ресурсов наружу.

Как включить Wake-On-LAN

Для того, чтобы начать использовать Wake-On-LAN, существует несколько вариантов его включения. Самый простой — через BIOS материнской платы. Другой вариант через специальную утилиту от производителя вашей материнской платы или сетевой карты.

В BIOS

Большинство старых компьютеров и многие современные имеют собственные настройки Wake-On-LAN, зашитые в BIOS. Для того, чтобы войти в BIOS, Вам нужно нажать на кнопку DEL или F1 или F2 при загрузке компьютера, После входа в BIOS перейдите в настройки питания (Power) или Дополнительные настройки (Advanced Options).


Award BIOS

В UEFI BIOS настройка включения Wake-On-LAN обычно находится в дополнительных опциях, иногда — в разделе Включение питания PCIE / PCI.

Также производители материнских плат называют технологию иначе: Aggresslive Link от ASRock, ErP от Gigabyte, PME от ASUS.


UEFI BIOS

В операционной системе Windows

Вы также можете включить Wake-On-LAN в операционной системе. Как это сделать в Windows. Откройте меню ПУСК и введите Диспетчер устройств . После открытия Диспетчера устройств разверните раздел Сетевые адаптеры . Щелкните правой кнопкой мыши на сетевой карте и выберите Свойства , затем перейдите на вкладку Дополнительно .

Прокрутите список, и найдите Wake on Magic Packet , Wake on LAN — каждый производитель называет эту настройку на свой лад. Измените значение на Enabled , если оно выключено.

Теперь перейдите на вкладку Управление электропитанием , и убедитесь, что опция Разрешить устройству будить компьютер включена. Дополнительно можно установить галку напротив Разрешить только волшебному пакету будить компьютер .

В macOS

Откройте системные настройки и выберите Энергосбережение . Отметьте опцию Wake for Network Access или что-то подобное. Это позволит включить Wake-on-LAN.


В Linux

У Ubuntu есть отличный инструмент, который может проверить, поддерживает ли сетевая карта Wake-on-LAN и можно ли его включить. Откройте терминал и установите ethtool, используя следующую команду:

Sudo apt-get install ethtool

А поддержку Wake-on-LAN можно, запустив:

Если у Вас сетевой интерфейс другой eth2, eth3, eth4 и так далее, замените его.


Найдите пункт Wake-on . Чтобы включить эту опцию, используйте следующую команду:

Sudo ethtool -s eth0 wol g

Повторно запустите команду , чтобы убедиться во включении. Должно быть Wake-on: g .

Как включить компьютер с помощью Wake-on-LAN

Чтобы отправлять запросы Wake-on-LAN, есть несколько доступных вариантов:

Depicus для Windows, Apple и Android

У Depicus есть отличная серия легких инструментов для выполнения этой работы, включая графический интерфейс для Windows и командную строку для Windows и MacOS. Кроме того доступно отдельное приложение на Android, iPhone и Windows Mobile.

Wake on LAN (WOL) — технология, позволяющая удаленно включить компьютер через локальную сеть или через Интернет. (ссылка на википедию: https://ru.wikipedia.org/wiki/Wake-on-LAN )

Программа для включения Wake on LAN: http://www.syslab.ru/wakeon

Для использование технологии «Wake On Lan» (технология «Magic packet») должно быть:

1. Оборудование должно соответствовать спецификации ACPI и в настройках BIOS должна быть включена поддержка режима «Wake On Lan».

2. Иметь блок питания ATX.

3. Иметь сетевую карту, поддерживающую технологию «Wake On Lan» (WOL).

4. Настроить Wake on LAN через Роутер. (примеры настройки)

Настройка

1. Включаем WOL в BIOS

Определить, поддерживает ли материнская плата вашего компьютера Wake On Lan, можно. зайдя в настройки CMOS Setup в раздел настроек управления питанием. Найдите там опцию«Wake On Lan» и убедитесь, что она включена.

Пример : «Power — APM Configuration» AMI BIOS v2.61:

Для включения режима Wake On Lan необходимо установить пункт «Power On By PCI Devices» в «Enabled»

2. Настройка linux для Wake On Lan

Ставим пакет ethtool (apt-get install ethtool)

Проверяем поддерживает ли карта «Supports Wake-On»

ethtool eth0 | grep –i wake-on

В строкеSupports Wake-On перечислены механизмы, поддерживаемые сетевой платой. В моём примере я пользуюсь методом отправки т. н.Magic Packet , и если вам нужно то же самое, то убедитесь, что вSupports Wake On присутствует буква«g» . Буква«d» в строкеWake-on обозначает, что Wake On Lan для данного сетевого интерфейса отключён. Чтобы включить его в режим распознавания Magic Packet, необходимо:

ethtool s eth 0 wol g

прим ifconfig eth0 | grep –i hwaddr

Настройка Windows для Wake On Lan

— Нажмите клавишу Пуск и в поиске задайте «Управление компьютером». Найдите из списка устройств ваш сетевой адаптер. Правой кнопкой мышки на нем выберите из меню «Свойства» (Properties), а затем найдите закладку «Дополнительно» (Advanced). Прокрутите список и найдите в нем следующий пункт «Пробуждение от Магического Пакета» (Wake on Magic Packet) или что-то вроде того, и установите значение в положение «Включено» (Enabled). Нажмите на клавишу ОК когда закончите.

— Также вам потребуется знать мак адре сетевой карты ipconfig – all

— Практика использования Wake On Lan выявила еще один момент, — некоторые компьютеры при разрешении режима включения по сети в настройках BIOS, включают электропитание самостоятельно, даже не получив кадр с Magic Packet»ом. Причиной данного явления является то, что у некоторых сетевых карт (замечено у Intel, 3COM) для включения электропитания по локальной сети используют не только WOL, но и другие события (Wake on ARP, Wake on Link Change и т.п.), при чем, по умолчанию задействованы сразу несколько критериев включения. Нужно убрать из настроек адаптера (как правило, с помощью специальной утилиты) лишние условия, и все будет работать правильно.

Настройка MACOS для Wake On Lan

Откройте окно «Системные настройки» (System Settings) и выберите Energy Saver. На вкладке «Опции» (Options) вы должны увидеть фразу «Пробуждение от Ethernet» или что-то похожее. Эта опция включает функцию Wake-on-LAN.

Настройка FreeBSD для Wake On Lan

С каждым релизом FreeBSD все больше и больше драйверов сетевых карт получают поддержку Wake-on-LAN.
http://forums.freebsd.org/threads/wake-on-lan.28730/ (тут обсуждается как подсунуть драйвер)

3.Роутеры:

a. ZyXEL : Wake on LAN через интернет-центр серии Keenetic (http ://zyxel .ru /kb /2122)

b. Пример настройки роутера TP-Link :

1. зайдите в раздел Forwarding->Virtual Servers

2. добавит «виртуал сервер» указать его IP адрес и порт, который будет использоватся для включения. Обычно для Wake-On-LAN используется порты 7 и 9, но можно также указать любой другой порт (от 1 до 65535). Для типа протокола задайте значение UDP или ALL.

3. Зайдите IP & MAC Binding->Binding Settings Включить опцию Arp Binding .

4. Добавить новую запись для компьютера который вы будете удаленно включать указав его IP и MAC адреса. Не забудьте также для него включить опцию Bind .

c. Пример настройки роутера mikrotik:

Заметка: В mikrotik есть встроенная утилита tool wol которая позволяет прямо с роутера включить компьютер. (http://wiki.mikrotik.com/wiki/%D0%A0%D1%83%D0%BA%D0%BE%D0%B2%D0%BE%D0%B4%D1%81%D1%82%D0%B2%D0%B0:%D0%98%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BC%D0%B5%D0%BD%D1%82%D1%8B_(Tools)/Wake-on-LAN )

Пример настройки микротик для включения компьютера через syslab :

1. Создаем статическую запись в ARP таблице для broadcast

> /ip arp add address=192.168.1.254 disabled=no interface=bridge-local mac-address=FF:FF:FF:FF:FF:FF

2. Создаем статическую запись в ARP таблице для компьютера пользователя

Зачастую на форум поступают различные вопросы. На них, по возможности, даются оперативные ответы. А порой, количество одинаковых по содержанию вопросов начинает резко зашкаливать. И это явление не обошло стороной технологию Wake-On-Lan, получившей реализацию на массе системных плат производства GIGABYTE.

На сегодняшнем примере с картинками будет предпринята попытка внести немного ясности в особенности настройки и работы WOL. Что такое Wake-On-Lan и зачем она нужна, можно ознакомиться на всезнающем сайте Википедии:

Начну с конфигурации. Использовалось следующее оборудование:

Системная плата GIGABYTE GA-Z77X-D3H

Процессор Intel Core i5 -2300

Система охлаждения Intel BOX Cooler

Оперативная память Kingston KHX11000D3LL/2G, подключенная в DDR3_1 слот

Накопитель wd1002faex

Блок питания CFT-1000G-DF

Операционная система Windows 7 Professional x64

Итак, считается, что система собрана, протестирована, работает должным образом и включена в состав локальной сети. Однако, для гарантированно верных настроек в среде UEFI, необходимо всё равно привести её к единообразию и гармонии. Для этого нужно провести процедуру очистки CMOS. Это делается замыканием двух контактов CLR_CMOS с помощью металлической перемычки ПРИ АБСОЛЮТНО ОБЕСТОЧЕННОЙ СИСТЕМЕ . Но мы воспользовались проверенным, дедовским методом, и замыкали контакты отвёрткой☺

Подробная информация по процедуре обнуления CMOS приведена в официальном руководстве к системной плате.

После, система включается, и впоследствии на экран выводится сообщение о свершении перезагрузки BIOS, и предлагается выбрать нужный вариант действий. Выбирается третий – вход в меню настроек BIOS.

После обнуления CMOS, все параметры приводятся к заводским установкам и, следовательно, вариант того, что какие-то настройки повлияли на необходимые для корректной работы функции WOL, исключается.

В среде UEFI необходимо перейти в Advanced mode (туда, где нет красивых видов на плату). Делается это нажатием клавиши F1. Далее, нужно перейти в меню Power Management, и убедится, что параметр ErP (именно он отвечает за WOL функционал) установлен в положение Disabled. Если не установлен – необходимо установить.

Итак, в среде операционной системы необходимо подготовить Ethernet адаптер к «прослушиванию» эфира на предмет получения «магического пакета». Этот пакет как раз предназначен для перевода компьютера из режима S5 в режим S0 в нужный момент, без физического участия пользователя. Для этого необходимо выполнить последующие настройки адаптера. Перейдём в меню управления компьютера, кликнув правой кнопкой мыши на иконке «Компьютер» рабочего стола, и выбрав пункт «управление»:

Переходим во вкладку «дополнительно». Там выбираем параметр «WOL Пакет Magic». Он должен быть включен. Если он выключен – включаем.

По сути, после этого компьютер уже готов просыпаться по команде «Magic packet’a» И всё что осталось сделать, так это узнать как его «разбудить». Но до этого необходимо выяснить, каким физическим и IP-адресом, на данный момент, обладает компьютер. Сделать это можно следующим образом:

Перейти в центр управления сетями и общим доступом (либо с помощью диспетчера устройств, либо посредством иконки в трее), выбрать текущее подключение по локальной сети и нажать там кнопочку «сведения». После, можно лицезреть обширную информацию относительно сетевого подключения. Нас интересуют графы «Физический адрес» (он же MAC) и Адрес IPv4. Записываем их на бумажку. В нашем случае это, соответственно, 50E549EDFCA3 и 192.168.100.55.

После, выключаем компьютер исключительно правильным способом, через «завершение работы». Это необходимо для того, чтобы сетевой адаптер продолжил корректно функционировать и получать «магические пакеты» после выключения компьютера.

После того как компьютер затихнет, можно убедиться в том, что сетевой адаптер продолжает работать, заветно подмигивая светодиодом:

Просьба обратить внимание, что дальнейшее обесточивание категорически неприемлемо. При выдёргивании из розетки кабеля питания или отключении сетевого фильтра «пилота», компьютер удалённо включиться не сможет.

Итак, теперь можно переходить непосредственно к процедуре удалённого включения компьютера. Делается это с помощью специального программного обеспечения, способного генерировать и посылать в нужный адрес «Magic packet». Такого программного обеспечения доступна огромная масса, и каждый может найти себе что-то персонально по своему вкусу. Мы же остановились на бесплатной утилите WOL 2.0.3. Устанавливается оно на сторонний компьютер, с которого, собственно, и будет производиться удалённое включение ожидающего «Magic Packet’a» компьютера.

Установка проходит найэлементарнейшим образом:

После программа запускается, и в ней необходимо произвести настройки по добавлению компьютера, который будет включаться удалённо. Для этого в главном окне жмём иконку «add new item», в появившемся окне вводим, записанные ранее на бумажку, IP и MAC адреса. Далее, нажимаем кнопку ОК.

После, в рядах списка главного окна, должна появиться запись о компьютере с введёнными ранее параметрами. Выделяем запись ниже колонки «Host», иконки взаимодействия становятся активными, и нажимаем на ту, которая называется «Wake-up». После этого действия на удалённый компьютер будет отправлен заветный «Magic packet», и компьютер отреагирует так, словно была нажата кнопка Power, или, проще говоря, включится.

Вот так, вкратце, выглядит процедура удалённого включения компьютера на базе системной платы GIGABYTE с помощью технологии Wake-On-Lan. А вот что с компьютером делать дальше, как подключаться, как работать и как выключить – решать Вам, ибо это уже совсем другая история☺

27 октября 2016 в 23:58
  • Системное администрирование

… а также без проброса портов, SSH/telnet и установки сторонних приложений. С любого компьютера, подключённого к интернет и даже с телефона!

Периодически мне бывает нужно включить домашний компьютер, когда я нахожусь не дома. Обычно я не запаривался и звонил или отправлял сообщение с такой просьбой жене, которая сидит дома в декрете. Очень удобное средство удалённого управления с голосовым интерфейсом. Однако у этого способа есть ряд недостатков — ушла гулять, укладывает ребёнка, или ещё чем либо занята. Хотелось простого решения из того что есть под рукой.

Первым делом включаем Wake on LAN в BIOS»е материнской платы, у всех это делается по-своему, у многих включено по умолчанию. На одном из моих ПК даже такой опции нету — всегда включено.

Далее переходим в WinBox и подключаемся к вашему роутеру (если хотите, можете через SSH или через HTTP(S), я всё делаю в WinBox»е). Если открыть текстовую консоль RouterOS и пошарить там в разделе /tool (или в wiki-мануалах), то можно обнаружить утилиту wol со следующим синтаксисом:

/tool wol mac=XX:XX:XX:XX:XX:XX interface=ifname
Где ifname — имя интерфейса, с которого будет рассылаться волшебный пакет, XX:XX:XX:XX:XX:XX — mac адрес вашего компьютера.

Вроде всё просто, но Winbox с телефона не особо запускается и mac адрес по памяти замучаешься вводить. Можно запускать SSH и отправлять в него одну единственную команду, но это тоже долго и нудно. Используем фаервол!

Напрямую из правил фильтра запускать исполнение команд нельзя, из всех действий нам больше всех подойдёт добавление адреса в address-list, т.к. оно позволяет создать новый объект в операционной системе роутера, доступный из скриптов.

Добавим новое правило для цепочки input и расположим его среди других разрешающих правил этой цепочки. Укажем протокол tcp и dst-port — любой из верхних портов.

Действие выберем add src (можно и dst) to address list, укажем имя листа.


Для отслеживания появления записей используем планировщик. Заходим System -> Sheduler, создаём задание планировщика, задаём имя. Указываем Start time: startup, и желаемый интервал, к примеру каждые 15 секунд.

В поле on event напишем простенький скрипт:

:local WAKEPC :if ($WAKEPC!=»») do={ /tool wol mac=00:11:22:33:44:55 interface=bridge_lan /ip firewall address-list remove }
Не забываем указать правильный mac, имя интерфейса и адрес-листа. Данный скрипт при обнаружении элементов в адрес-листе выполнит команду, отправляющую магические пакеты на ваш компьютер, после чего удалит запись из адрес-листа.

Для включения вашего компьютера достаточно открыть браузер и перейти на IP вашего микротика, указав порт, который мы задали в правиле фаервола: http://your.router.net:port , после чего фаервол создаёт запись в адрес-листе, задание планировщика обнаружит эту запись, выполнит запуск утилиты wol, и удалит запись из адрес-листа. Проще паренной репы, можем добавить адрес в избранное, чтобы каждый раз не вводить.

Только не забывайте про безопасность, данный способ ничем не защищён и кто угодно может включить Ваш компьютер, зная или подобрав нужный порт. Для защиты можно использовать VPN, port knocking, whitelist или метод Неуловимого Джо — решать Вам. Если Вам требуется включать таким образом по-отдельности несколько компьютеров, создайте соответствующее количество правил на разных портах, каждое из которых будет кидать адреса в свой адрес-лист, скрипт в задании планировщика также размножаем через Ctrl+C, Ctrl+V, либо создаём отдельные задания для каждого — как хотите.

MikroTik. Пакеты RouterOS — CloudHosting FAQ

MikroTik. Пакеты RouterOS

RouterOS поставляется с определенным набором пакетов, которые обеспечивают базовую функциональность. Так как эта операционная система довольно универсальная — есть множество пакетов, которые расширяют функционал этой сетевой системы. Пакеты поставляются только компанией Mikrotik и не могут быть поставлены от сторонних разработчиков. Для того, что-бы подключить пакет его нужно скачать с официальной страницы, разархивировать и забросить в корень вашего маршрутизатора. После перезагрузки это пакет будет установлен.

Доступность пакетов может отличатся от выбранной платформы (mipsle, mipsbe, ppc, x86). Главным пакетом является пакет system, его нельзя удалить, он является дефолтным на всех роутерах. Кроме него с коробки довольно большое количество пакетов включено в поставку для устройства Mikrotik. Это и пакет DHCP, ppp и другие. Стоит помнить, что эти пакеты не являются обязательными и могут быть отключены или удалены с маршрутизатора.

Пакеты можно устанавливать в разделе /system package

Для домашнего или офисного роутера достаточно оставить минимальное количество пакетов — для экономии ресурсов маршрутизатора. Это advanced-tools — пакет для диагностики сети, dhcp — пакет DHCP-сервера и клиента, ppp — VPN-сервер и клиента, security — безопасное подключение к WinBox, system — дефолтный пакет, wireless — пакет поддержки беспроводной сети.

Для того, что-бы отключить пакет нужно выделить его и нажать на кнопку Disable — это запланирует отключение пакета при следующей перезагрузке устройства. Если нажать кнопку Uninstall — пакет будет удален во время перезагрузки. Кнопка Unschedule — удалит запланированное задание для выделенного пакета.

Список пакетов

advanced-tools (mipsle, mipsbe, ppc, x86) Инструменты ping tools. netwatch, ip-scan, sms tool, wake-on-LAN

calea (mipsle, mipsbe, ppc, x86) Пакет, который предоставляет возможность перехвата и журналирования сетевого трафика с помощью правил брандмауэра и также может работать в качестве сервера хранения данных. В октябре 1994 года Конгресс США принял дополнительные меры по защите общественной и национальной безопасности, утвердив положения закона о помощи телекоммуникационных компаний правоохранительным органам, под общим названием Communications Assistance for Law Enforcement Act (CALEA). Одной из главных задач CALEA стало формирование такой системы взаимодействия между спецслужбами и операторами, при которой правоохранительным органам не требовалось бы иметь собственных специалистов по каждой технологии связи, но имелась бы возможность получать от поставщиков услуг готовую, интересную, с точки зрения проведения оперативно-розыскных мероприятий, информацию.

dhcp (mipsle, mipsbe, ppc, x86) Dynamic Host Control Protocol. Включает возможность использования DHCP-сервера и DHCP-клиента.

gps (mipsle, mipsbe, ppc, x86) Поддержка GPS (Global Positioning System). Пакет нужен при подключении внешнего модуля GPS.

hotspot (mipsle, mipsbe, ppc, x86) Включает HOTSPOT-сервер на маршрутизаторе.

ipv6 (mipsle, mipsbe, ppc, x86) Поддержка IPv6-протокола.

mpls (mipsle, mipsbe, ppc, x86) Включение поддержки MPLS (Multi Protocol Labels Switching). Механизм в высокопроизводительной телекоммуникационной сети, осуществляющий передачу данных от одного узла сети к другому с помощью меток.

multicast (mipsle, mipsbe, ppc, x86) Включается поддержку Multicast.

ntp (mipsle, mipsbe, ppc, x86) Включает NTP-сервер и клиент в роутере. Стоит сказать что SNTP client уже включен в пакет system, и если вам не нужен NTP-сервер смысла в его установке нет.

openflow (mipsle, mipsbe, ppc, x86) Включает поддержку OpenFlow.

ppp (mipsle, mipsbe, ppc, x86) Включает MlPPP client, PPP, PPTP, L2TP, PPPoE, ISDN PPP клиенты и сервер.

routerboard (mipsle, mipsbe, ppc, x86) Доступ и управление RouterBOOT. RouterBOARD информация.

routing (mipsle, mipsbe, ppc, x86) Включает поддержку динамических протоколов маршрутизации RIP, BGP, OSPF, а так-же BFD и фильтры для маршрутов.

security (mipsle, mipsbe, ppc, x86) Включает поддержку IPSEC, SSH, и Secure WinBox

system (mipsle, mipsbe, ppc, x86) Базовый пакет, который включается в себя static routing, ip addresses, sNTP, telnet, API, queues, firewall, web proxy, DNS cache, TFTP, IP pool, SNMP, packet sniffer, e-mail send tool, graphing, bandwidth-test, torch, EoIP, IPIP, bridging, VLAN, VRRP.Кроме того — MetaROUTER, Virtualization.

ups (mipsle, mipsbe, ppc, x86) Включает интерфейс управление UPS фирмы APC.

user-manager (mipsle, mipsbe, ppc, x86) MikroTik User Manager — биллинг от компании Mikrotik.

wireless (mipsle, mipsbe, ppc, x86) Пакет, который обеспечивает работу беспроводного интерфейса в Mikrotik.

arlan (x86) Поддержка Aironet Arlan — устаревшей беспроводной технологии.

isdn (x86) Поддержка модемов ISDN.

lcd (x86) Поддержка сторонних LCD-панелей, которые подключаются через serial/parallel port. Пакет не требуется для встроенных сенсорных панелей в RouterBoard.

radiolan (x86) Включает поддержку RadioLan карт.

synchronous (x86) Поддержка FarSync. Служится для репликации.

xen ( discontinued x86) XEN Virtualization — включение виртуализации.

kvm (x86) KVM Virtualization — включение виртуализации.

tr-069 (mipsle, mipsbe, ppc, x86) Technical report 069 — протокол CPE WAN Management (CWMP) для удаленного управления устройством.

routeros-mipsle (mipsle) Пакет для платформы mipsle (RB100, RB500). По-умолчанию включает в себя system, hotspot, wireless, ppp, security, mpls, advanced-tools, dhcp, routerboard, ipv6, routing.

routeros-mipsbe (mipsbe) Пакет для платформы mipsbe (RB400). По-умолчанию включает в себя system, hotspot, wireless, ppp, security, mpls, advanced-tools, dhcp, routerboard, ipv6, routing.

routeros-powerpc (ppc) Пакет для платформы powerpc (RB300, RB600, RB1000). По-умолчанию включает в себя system, hotspot, wireless, ppp, security, mpls, advanced-tools, dhcp, routerboard, ipv6, routing.

routeros-x86 (x86) Пакет для платформы x86 (Intel/AMD PC, RB230). По-умолчанию включает в себя system, hotspot, wireless, ppp, security, mpls, advanced-tools, dhcp, routerboard, ipv6, routing.

Wake-On-Lan из общедоступной сети (практический пример MikroTik)

Функция Wake-On-Lan

Некоторые сетевые устройства и ПК могут прослушивать входящие специальные пакеты на своих интерфейсах Ethernet даже при выключении, и это используется для их включения с помощью специального магического пакета , который используется Wake-On-Lan (от теперь ВОЛ).

WOL обычно выполняется путем создания пакета с IP-адресом назначения и широковещательным адресом сети (в общем 192.168.0.0/24, он направляется на 192.168.0.255 или 255.255.255.255), что создает кадр Ethernet с FF:FF:FF:FF:FF:FF mac-адресом назначения. Этот широковещательный кадр обрабатывается всеми хостами в сегменте локальной сети. Что делает этот пакет волшебным ? Тот факт, что он должен содержать Mac-адрес устройства, которое нужно разбудить, повторяется 16 раз. Когда сетевая карта выключенного устройства обнаруживает этот специальный кадр, она включает устройство.

Обычно волшебный пакет представляет собой пакет UDP с портом назначения 0, 7 или 9, но это не обязательно.Кстати, в примерах я буду использовать UDP-порт 9.

Дополнительную информацию о WOL можно найти в Википедии.

Использование WOL из Интернета

Предположим, что у вас есть NAS в вашей домашней сети, который вы хотите включать только при необходимости, чтобы получить некоторые документы, которые вы сохранили на нем, и что у вас нет других активных устройств в домашней сети, к которым вы можете подключиться. подключиться, чтобы использовать WOL, не было бы полезно иметь возможность использовать WOL из Интернета? Как мы можем создать широковещательный кадр во внутренней локальной сети из общедоступной сети?

Я построил эту простую установку в симуляторе сети Eve-NG с виртуальным маршрутизатором MikroTik, который имитирует наш домашний маршрутизатор, с eth2 в качестве интерфейса WAN (я использую частную IP-адресацию в 192. 168.60.0/24, но считайте, что это общедоступный адрес в Интернете) и eth3-3-4, сгруппированные в мост под названием lan_bridge с IP-адресом 192.168.1.1/24 и включенным DHCP-сервером с 192.168.1.10-192.168. 1.50 пул адресов, доступных для клиентов во внутренней локальной сети.

Мы могли бы сгенерировать волшебный пакет, направленный на общедоступный IP-адрес нашего домашнего маршрутизатора, но как мы можем заставить его изменить его на широковещательный пакет? Первое самое простое решение, которое пришло мне в голову, заключалось в том, чтобы использовать NAT назначения для изменения волшебного пакета, предназначенного для 192.168.60.141 на 192.168.1.255, но на маршрутизаторах MikroTik или Linux это не работает (я думаю, что направленная широковещательная переадресация не поддерживается) и пакет отбрасывается.

Итак, как мы можем сгенерировать волшебный пакет в локальной сети 192.168.1.0/24 для питания наших устройств? Мы можем реализовать следующий трюк:

  1. Выделить неиспользуемый IP-адрес в 192. 168.1.0/24, например 192.168.1.100
  2. Определите статическое разрешение ARP на маршрутизаторе MikroTik, установив FF:FF:FF:FF:FF:FF как 192.168.1.100 мак адрес
  3. Реализуйте правило nat назначения перед маршрутизацией на маршрутизаторе MikroTik, чтобы изменить входящий трафик, направляемый на его интерфейс с выходом в Интернет, и на UDP-порт X (давайте выберем 9999), изменив адрес назначения на 192.168.1.100 и порт назначения на 9

И вуаля, теперь, когда вы отправляете волшебный пакет на 192.168.60.141 с портом назначения 9999/UDP, предварительная обработка NAT MikroTik изменит адрес назначения на 192.168.1.100. Затем MikroTik направит пакет к lan_bridge, который находится в этой подсети, и когда он подготовит кадр Ethernet, который будет содержать переадресованный пакет, он поставит FF:FF:FF:FF:FF:FF в качестве Mac-адреса назначения, таким образом, создавая широковещательный пакет во внутренней локальной сети, даже если IP-адрес назначения является одноадресным IP-адресом.

Предупреждение системы безопасности: пакет, отправленный через порт 9999/UDP на общедоступный адрес вашего маршрутизатора, создаст широковещательный пакет во внутренней сети, поэтому настоятельно рекомендуется ограничить количество пересылаемых пакетов.

Конфигурация MikroTik

Базовая конфигурация
 # Мост eth3-3-4
/интерфейсный мост
добавить имя = lan_bridge
/интерфейс моста vlan
добавить мост = lan_bridge vlan-ids = 1
/порт моста интерфейса
добавить мост=интерфейс lan_bridge=ether2
добавить мост=интерфейс lan_bridge=ether3
добавить мост=интерфейс lan_bridge=ether4

# Включить DHCP-клиент на eth2 (интерфейс WAN)
/ip DHCP-клиент
добавить disabled=нет интерфейса=ether1

# Настройте внутреннюю сеть и включите DHCP-сервер
/айпи адрес
добавить адрес=192.168.1.1/24 интерфейс = сеть lan_bridge = 192.168.1.0
/IP пул
добавить имя = диапазоны dhcp_pool = 192.168.1.10-192.168.1.50
/ip DHCP-сервер
добавить адрес-пул = dhcp_pool disabled = нет интерфейса = имя lan_bridge = dhcp_server
/ip сеть dhcp-сервера
добавить адрес = 192. 168.1.0/24 шлюз = 192.168.1.1 маска сети = 24 

«Трюк» разрешения ARP
 /IP Арп
добавить адрес = 192.168.1.100 интерфейс = lan_bridge mac-address = FF: FF: FF: FF: FF: FF 

Брандмауэр NAT и правила переадресации

Как было предложено ранее, мы реализуем правило переадресации, разрешающее трафик, направленный на 192.168.1.100, но с проверкой ограничения скорости, которая разрешает 1 пакет каждые 10 секунд с определенного общедоступного исходного адреса с пакетом из 3 (это фактически позволяет пересылать 4 пакета, это может быть связано с тем, как MikroTik dst-limit работает, я не особо вникал в это, так как практический эффект для целей этого HowTo одинаков).

 /ip брандмауэр физ.
добавить action=dst-nat chain=dstnat dst-port=9999 in-interface=ether1 log=yes log-prefix=PRE-RT: protocol=udp \
    адреса = 192.168.1.100 до портов = 9

/IP фильтр брандмауэра
добавить action=accept chain=forward dst-address=192. 168.1.100 dst-limit=1/10s,3,src-address in-interface=ether1 log=yes \
    log-prefix=FWD: out-interface=lan_bridge
добавить action=drop chain=forward log=yes log-prefix=DROP: 

Здесь можно посмотреть всю конфигурацию в более читабельном формате с подсветкой синтаксиса в Sublime Text:

Тестирование настройки MikroTik

Чтобы проверить, что я реализовал, я загрузил на свой MacBook Pro пакет программного обеспечения wakeonlan (из MacPorts) и сгенерировал 10 волшебных пакетов подряд с помощью следующей команды (sudo запрашивает пароль только первый время, поэтому команда повторяется 10 раз очень быстро):

 % для i в $(seq 1 10) ; сделать sudo wakeonlan -i 192.168.60.141 -p 9999 aa:bb:cc:dd:ee:ff ; Готово
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192. 168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff
Отправка волшебного пакета на 192.168.60.141:9999 с aa:bb:cc:dd:ee:ff 

Я выбрал aa:bb:cc:dd:ee:ff в качестве Mac-адреса устройства, которое нужно разбудить. Давайте посмотрим на журналы MikroTik, чтобы увидеть, что происходит:

(щелкните здесь, чтобы увидеть полноразмерное изображение)

Как видите, правило Pre-Routing NAT (цепочка src-nat) срабатывает 10 раз из-за 10 вышеперечисленных пакетов, но правило переадресации, разрешающее прохождение трафика, срабатывает только 4 раза, остальные 6 раз мы есть капля.

Я также начал захват пакетов на ПК-интерфейсе Fa0/0 (это виртуальный маршрутизатор, поэтому интерфейс имеет такое название). Интерфейс Fa0/0 подключен к MikroTik lan_bridge через интерфейс eth3 MikroTik, фактически он получает IP-адрес по DHCP:

 PC#sh аренда DHCP
Временный IP-адрес: 192.168.1.49 для однорангового интерфейса: FastEthernet0/0
Временная маска подсети: 255.255.255.0
Арендный DHCP-сервер: 192.168.1.1, состояние: 5 привязка
Идентификатор транзакции DHCP: 18AE
Аренда: 600 сек., Обновление: 300 сек., Повторная привязка: 525 сек.
Временный адрес шлюза по умолчанию: 192.168.1.1
Следующий таймер срабатывает через: 00:04:53
Количество повторных попыток: 0 Идентификатор клиента: cisco-c202.0c94.0000-Fa0/0
Шестнадцатеричный дамп идентификатора клиента: 636973636F2D633230322E306339342E
303030302Д4661302Ф30
Имя хоста: ПК 

Интерфейс Fa0/0 получает волшебный пакет из-за его MAC-адреса назначения FF:FF:FF:FF:FF:FF, но затем он игнорирует пакет, поскольку он не содержит трафика, предназначенного для его IP-адреса. Единственная цель ПК — сделать сегмент локальной сети активным в лаборатории и показать прием магических пакетов по внутренней локальной сети. На следующем изображении вы можете увидеть 4 волшебных пакета, содержащих mac-адрес aa:bb:cc:dd:ee:ff 16 раз:

Вы также можете сгенерировать волшебный пакет через телефон с такими приложениями, как WOL на IOS:

. Вы можете настроить домашний маршрутизатор для регистрации общедоступного IP-адреса в такой службе, как No-IP, а затем настроить свое приложение WOL с зарегистрированным полным доменным именем (например, myhomenetwork.no-ip.org ).

Выводы

За эту идею спасибо моему боссу Г.2, который может управлять моим интернет-соединением 1 Гбит / с, с пиками скорости беспроводной передачи данных 4-500 Мбит / с на 5 ГГц, с десятками правил брандмауэра, двумя соединениями pppoe (одно в специализированном vrf, возможно, это будет темой следующей статьи) ) и сценарии, работающие в фоновом режиме, для управления динамическими списками контроля доступа (я проверяю IP-адреса некоторых известных полных доменных имен и добавляю их в список надежных источников со сроком действия, чтобы разрешить доступ только к некоторым общедоступным IP-адресам службы в моей домашней сети). Если вам нравится экспериментировать, загляните на сайт MikroTik, а если вы хотите поэкспериментировать, не тратя ни евро, просто загрузите виртуальный образ облачного маршрутизатора MikroTik и запустите его в сетевом симуляторе EVE-NG, чтобы повеселиться! 😉

Нравится:

Нравится Загрузка…

Родственные

Пробуждение по локальной сети перед подключением к удаленному рабочему столу

Пробуждение по локальной сети перед подключением к удаленному рабочему столу — MikroTik Script RouterOS
 Если у вас дома есть ПК и вам нужно подключаться к нему через RDP в произвольное время, но вы не хотите тратить деньги на электроэнергию, необходимую для поддержания работы ПК в течение всего дня, то это решение — то, что вам нужно для.Во-первых, обратите внимание на мою конфигурацию:

Сначала я проверяю, есть ли какие-либо новые подключения к моему переадресованному порту RDP:

  /ip firewall nat add action=add-dst-to-address-list address-list=RDP250 chain=dstnat comment=HTPC dst-address=MY-PUBLIC-IP dst-port=MY-RDP-PORT in-interface= протокол ether10=tcp to-addresses=10. 0.0.250 to-ports=3389 
Затем я сделал «шпильку» NAT, чтобы я мог получить доступ к своему компьютеру через свое имя хоста из любого места (внутренней сети и Интернета):

  /ip firewall nat add action=dst-nat chain=dstnat comment=HTPC dst-address=MY-PUBLIC-IP dst-port=MY-RDP-PORT in-interface=ether10 protocol=tcp to-addresses=10.0.0.250 портов = 3389
/ip firewall nat add action=masquerade chain=srcnat comment="HTPC - Шпилька" dst-address=10.0.0.250 dst-port=MY-RDP-PORT out-interface=bridge1 protocol=tcp src-address=10.0.0.0/ 24 
Итак, когда я попытался получить доступ к ПК через RDP, Mikrotik добавил мой общедоступный IP-адрес в список адресов, а затем подключил меня к NAT. Но что, если ПК находится в режиме ожидания?

Я создал этот небольшой скрипт, чтобы проверить, есть ли какие-либо IP-адреса в списке адресов RDP250:

  :foreach A in=[/список IP-адресов брандмауэра find name=RDP250] do={
  если ([/список адресов брандмауэра ip get $A list]="RDP250") do={
    :log информация "Отправка WoL на адрес $[/ip firewall address-list get $A address]"
    /tool ​​wol mac=ПК-MAC-АДРЕС интерфейс=мост1
    :log информация "Удаление IP-адреса $[/ip firewall address-list get $A address] из списка"
    /ip-список адресов брандмауэра удалить $A
  }
} 
И планировщик для запуска этого скрипта каждые 10 секунд. В 99% случаев RDP-клиент подключался с первой попытки, в течение 5 секунд. В худшем случае вам придется дважды пытаться подключиться.

Обратите внимание, что сценарий довольно маленький и простой и не будет влиять на ЦП, если у вас нет большого количества адресов в списке. Так что будьте осторожны при этом. Альтернативой является подключение к маршрутизатору и отправка пакета WoL вручную.

Обратите внимание, что у меня нет статического IP-адреса на моем интерфейсе WAN. Вместо этого я обновляю IP через мой уже активный планировщик ChangeIP с помощью этой дополнительной строки кода:

  /ip firewall nat set [/ip firewall nat find comment=HTPC] dst-address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] 
Полная статья о ChangeIP находится здесь http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_ChangeIP.com

Оригинал статьи: http://www.plecko.com.hr/?permalink_static=123.

Кредит: https://wiki.mikrotik.com/wiki/Wake_on_Lan_before_connection_to_Remote_Desktop
 

Лучшие советы Mikrotik ~ Бинарное сердцебиение


Запуск микротиков в полевых условиях? Вот мои главные советы, как максимально эффективно использовать возможности Mikrotik:

1. Безопасность
1.1 — Пользователи и пароли
1.2 — Порты доступа
1.3 — Защита от взлома методом грубой силы
1.4 — Анонимизация вашего соединения
2. Резервное копирование вручную (и почему резервное копирование не является резервным)
3. Блокировка сайтов
5. Удаленное пробуждение компьютера
6. Удаленный доступ к вашей сети

1. Защита вашего маршрутизатора.


Однажды я установил новый маршрутизатор на краю своей сети, подключившись к новому провайдеру. После установки я отправился в десятиминутную поездку домой, откуда я планировал выполнить настройку. К тому времени, как я вернулся домой, роутер уже был скомпрометирован. Я не могу переоценить важность защиты вашего маршрутизатора, это абсолютно необходимо с точки зрения поддержания стабильной сети.
1.1 Пользователи и пароли

Имя пользователя Mikrotik по умолчанию — admin, и у него нет пароля. Мой первый шаг при настройке нового маршрутизатора — удалить пользователя-администратора и заменить его чем-то более безопасным:

.

Войти с помощью WinBox

В меню слева выберите System->Users:

.

Здесь вы увидите крайне оскорбительного пользователя-администратора:

.

Прежде чем удалить его, давайте добавим нового пользователя и убедитесь, что новый пользователь может войти в систему, для этого нажмите синий значок «+», чтобы добавить нового пользователя:

Заполните желаемое имя пользователя, наличие безопасного имени пользователя усложняет любую атаку типа грубой силы.

Введите надежный надежный пароль и нажмите OK.

Теперь выйдите из маршрутизатора и снова войдите, используя нового пользователя и пароль. Однажды я совершил ошибку, удалив пользователя-администратора, войдя в систему как пользователь-администратор, а затем я не смог снова войти в систему из-за опечатки в новом имени пользователя.

Теперь вы можете приступить к удалению пользователя-администратора, перейдя в System->Users , выбрав пользователя-администратора и щелкнув красный значок «-»:

1.
2 Порты доступа

Как и в случае с любым устройством, подключенным к Интернету, запуск служб на их портах по умолчанию является приглашением для взлома.Первый и самый безопасный вариант — отключить все службы, которыми вы не будете пользоваться. Используете ли вы FTP для загрузки или загрузки файлов на маршрутизатор? Если нет, то выключите его. То же самое касается telnet, ssh и Winbox API.

Отключение портов:

Войдите в маршрутизатор с помощью Winbox, затем нажмите IP-> Services

.

Это вызовет окно «Службы», здесь вы можете выбрать службы, которые вы не собираетесь использовать, и нажать на красный «-», чтобы отключить их:

Лично я отключаю следующие службы, если у меня нет особой потребности в одной из них на этом конкретном маршрутизаторе:

  • фтп
  • www
  • телнет
  • API
  • API-SSL

Изменение портов:

В том же окне «Список IP-сервисов» дважды щелкните сервис, который вы хотите изменить:

.

В этом примере я изменю ssh с порта 22 на порт 9522.

Измените порт на новый порт, я просто использую существующий порт с добавлением двух цифр.

Нажмите «ОК»

Запишите номер порта, иначе вы не сможете использовать эту службу.

Порты, которые я меняю, следующие:

  • сш
  • www (где мне нужен веб-доступ к устройству)

1.3 Защита от грубой силы

Это взято прямо из Mikrotik Wiki и является одним из лучших способов гарантировать, что ваш маршрутизатор не может быть взломан, если кто-то найдет ваш SSH-порт после того, как вы его изменили.Приведенный ниже код блокирует атаки грубой силы FTP и SSH. Если вы изменили порты, на которых работают эти службы, не забудьте соответствующим образом изменить dst-порт ниже.

Откройте терминал на Winbox:

Вставьте следующий код в окно терминала:

/ip firewall filter

##Этот раздел блокирует FTP Brute Force
add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
comment=»drop ftp brute forcers»

add chain =output action=accept protocol=tcp content=»530 Неправильный вход» dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content=»530 Неверный логин» \
address-list=ftp_blacklist address-list-timeout=3h

##Этот раздел блокирует SSH Brute Force
add chain=input protocol=tcp dst-port=22 src-address-list= ssh_blacklist action=drop \
comment=»drop ssh brute forcers» disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src -to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment=»» disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src- список адресов = ssh_ stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment=»» disabled=no

add chain=input protocol=tcp dst-port=22 connection-state = новый src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment=»» disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment=»» disabled=no

1. 4 Сделайте ваше соединение анонимным

В наши дни невозможно узнать, кто шпионит за вашим интернет-соединением. Простой способ преодолеть это — найти провайдера VPN. Я не могу дать какие-либо рекомендации относительно того, какой сервис лучше для вас, так как это зависит от ваших конкретных требований. Однако я бы порекомендовал провайдера, который может предоставить соединение pptp или sstp.

Настройка VPN-туннеля на вашем Mikrotik:
Нажмите PPP в левом меню Winbox:


Нажмите на синий «+» и выберите «Клиент PPTP»:

На экране «Общие» вам нужно только дать соединению имя:
.
Перейдите на вкладку «Вызов» и введите данные, предоставленные вашим VPN-сервисом.Я выбрал «добавить маршрут по умолчанию», что означает, что весь трафик должен направляться через этот интерфейс. (Возможно, вам придется удалить любые другие маршруты по умолчанию и создать только один конкретный маршрут к вашему провайдеру VPN, который проходит через ваше интернет-соединение)

2.

Резервное копирование вручную (и почему резервное копирование не всегда является резервным)

Mikrotik предоставляет простую процедуру резервного копирования: вы просто открываете окно Files и нажимаете «Резервное копирование». Теперь у вас есть файл, который вы можете скачать и при необходимости восстановить.Но нет. Единственный раз, когда резервная копия будет восстановлена ​​на 100%, это когда вы восстанавливаете тот же файл конфигурации на той же маршрутизаторной плате с такими же беспроводными картами. Не похожие карты, не совсем карты той же модели, но точно такие же беспроводные карты вплоть до уровня mac-адреса. В противном случае будет восстановлена ​​только некоторая конфигурация, и может быть сложно понять, что работает, а что нет.

Лучший способ сделать резервную копию — выполнить экспорт, это даст вам файл с командами терминала, необходимыми для дублирования существующей конфигурации.Он также имеет дополнительную гибкость, позволяя вам экспортировать только определенную часть конфигурации, например, скажем, конфигурацию брандмауэра.

Чтобы сделать экспорт, откройте терминал внутри Winbox

.
В терминале введите следующую команду, обязательно выберите разумное имя файла:

файл экспорта=binaryboard13052015


Если вы сейчас откроете окно Files , вы найдете файл .rsc с указанным вами именем. Просто перетащите этот файл на локальный компьютер для безопасного хранения:

3..+(youtube.com|facebook.com).*$


3.4. Нажмите на вкладку «Правила фильтрации» в окне «Брандмауэр».
3.4.1 На вкладке «Общие» убедитесь, что выбрана цепочка «Вперед».

3.5. На вкладке «Дополнительно» в разделе «Протокол уровня 7» выбираем пункт «Блокировать», который мы создали ранее.


3.6. На вкладке «Действие» выберите «Отбросить» в качестве действия, а затем нажмите «ОК», чтобы закончить.

Альтернативный способ настроить блокировку — ввести (или вставить) в окно терминала следующее:

/ip firewall layer7-protocol
add name=Block regexp=»^. +(youtube.com|facebook.com).*\$»
/ip firewall filter
add action=drop chain=forward layer7-protocol=Block


Убедитесь, что вы протестировали все, прежде чем запускать его в производство. Также обратите внимание, что есть способы обойти это, если ваши пользователи достаточно умны или решительны.

5. Удаленное пробуждение компьютера

Если вам, как и мне, не нравится постоянно оставлять компьютер включенным, вы можете использовать маршрутизатор Mikrotik для отправки волшебного пакета WOL (Wake on Lan) на ваш компьютер.

Для этого вам необходимо знать MAC-адрес вашего компьютера. В зависимости от ваших настроек его можно найти на маршрутизаторе Mikrotik, перейдя по адресу IP->DHCP->Leases и найдя имя вашего компьютера.

Получив свой mac-адрес, откройте System->Scripts

Нажмите на синий значок «+»:
В окне «Новый сценарий» дайте сценарию разумное имя и добавьте следующий код в исходный код:

инструмент wol interface=ether1 mac=FF:FF:FF:FF:FF:FF


Теперь вы можете войти в свой маршрутизатор Mikrotik и запустить сценарий для удаленного пробуждения вашего компьютера. Пожалуйста, обратитесь к документации вашего ПК, чтобы включить WOL на ПК.

6. Удаленный доступ

Мы уже рассмотрели, как мы можем использовать VPN, чтобы скрыть трафик, теперь мы рассмотрим, как мы можем использовать VPN, чтобы получить удаленный доступ В нашу сеть.Опять же, мы будем использовать PPTP в качестве протокола VPN, так как он уже поддерживается большинством основных операционных систем. Обратите внимание, что вам понадобится публичный IP-адрес на маршрутизаторе.

Откройте окно PPP на Winbox:

Нажмите кнопку PPTP-сервер:

.

Установите флажок «Включено» и нажмите «ОК»

.

В окне PPP перейдите на вкладку Secrets и нажмите на синий «+»:

Настройте пользователя PPP следующим образом:

  • Имя: Имя пользователя, которое вы будете использовать для подключения
  • Пароль: пароль, который вы будете использовать для подключения
  • Служба: выберите PPTP для обеспечения безопасности
  • Локальный адрес: 10. 10.0.1
  • Удаленный адрес: 10.10.0.2
    (используемые вами адреса не имеют особого значения, если они не используются где-либо еще в вашей сети)
6.2 Подключение к VPN

В Windows 7/8 вы можете напрямую подключиться к своей сети с помощью встроенных инструментов VPN:

Откройте центр управления сетями и общим доступом и нажмите «Настроить новое подключение»

.

Выберите «Подключение к рабочему месту» и нажмите «Далее»

Выберите «Нет, создать новое подключение» и нажмите «Далее»

Выберите «Использовать мое подключение к Интернету»

.

Введите публичный IP-адрес вашего маршрутизатора и дайте имя подключению, завершите, нажав «Создать»:

.

Теперь вы найдете VPN-подключение под вашими доступными подключениями:

.

Когда вы подключитесь к нему, вам будет предложено ввести имя пользователя и пароль, которые вы создали ранее:

Dell OptiPlex — пробуждение по локальной сети с помощью Mikrotik

Dell OptiPlex — пробуждение по локальной сети с помощью Mikrotik

Мы хотим использовать функцию Wake on LAN через устройство Mikrotik.

О пробуждении по локальной сети — Wake-on-LAN — это стандартный отраслевой протокол для удаленного пробуждения компьютеров из режима очень низкого энергопотребления. Определение «режима пониженного энергопотребления» со временем немного изменилось, но мы можем считать его тем временем, когда компьютер «выключен» и имеет доступ к источнику питания. Протокол также позволяет использовать дополнительную функцию Wake-on-Wireless-LAN.

Требования:

Чтобы использовать Wake on LAN, необходимо выполнить следующие требования:

i) Функция пробуждения по сети, поддерживаемая сетевой картой (которая должна быть включена).

ii) Энергоэффективный Ethernet должен быть деактивирован.

iii) Программное обеспечение/инструмент, который активирует машину.

Шагов для подражания:

а) Определите mac-адрес машины с помощью команды ipconfig /all в Windows.

b) Включите функцию Wake on LAN в BIOS машины, которую необходимо включить.

 i) Войдите в BIOS (используя F12 в Dell OptiPlex 7010).

ii) Теперь перейдите в раздел «Управление питанием», затем нажмите «Пробуждение по локальной сети» и выберите параметр «Только локальная сеть».А затем применить и выйти из настроек.

iii) Теперь перейдите в Mikrotik Winbox и используйте команду /tool ​​wol, чтобы включить машину (вышеупомянутая машина, на которой мы включили функцию Wake on LAN в BIOS), используя ее mac-адрес (который был получен командой ipconfig /all).

Примечание : В mac-адресе мы заменили «-» на «:».

Ссылки

а) https://www.howtogeek.com/70374/how-to-geek-explains-what-is-wake-on-lan-and-how-do-i-enable-it/

б) https://www.dell.com/support/kbdoc/en-pk/000175283/how-to-setup-wake-on-lan-wol-on-your-dell-system

c) https://wiki.mikrotik.com/wiki/Manual:Tools/Wake_on_lan

Like this:

Like Loading…

Related

Mikrotik

我们希望看到良好、老式、可靠的 10G 网络与现代 CPU 相结合的全部潜力。 Mikrotik CCR2116-12G-4S+ 让您忘记设置中的 CPU 限制。与它的弟弟——令人惊叹的 CCR2004 一样,这款路由器配备了强大的 Amazon Annapurna Labs Alpine CPU。

但由于 16 个内核以 2 GHz 运行,例如,我们看到单核性能至少提高了 15%。当涉及基于每个连接处理的繁重操作时,这是最重要的方面。比如队列。 Mikrotik CR2116-12G-4S+ 在整个 CCR 产品系列中树立了单核性能的新标准!它支持第 3 层硬件卸载!

显然,您需要正确的连接来利用这种力量。有四个 10G SFP+ 端口。它们有一条独立的全双工线路连接到 Marvell Aldrin 系列开关芯片。然后我们有千兆以太网端口。其中 12 个正在运行 Marvel 芯片。出于管理目的还有另一个千兆端口直接连接到 CPU 。

每组 4 个端口与交换芯片有一个单独的全双工连接。这里没有瓶颈。在大多数设置中,您可以期待类似交换机的吞吐量。新一代处理器提供了令人惊叹的性能。 如果我们看一下 Mikrotik CCR1036——拥有 36 核 CPU 的强者,新的 CCR2116 可以轻松地将性能翻倍。 16 核与 36 核。性能翻倍。甚至更多。

如果您是一个相当大的 ISP,需要处理动态路由、海量 BGP、复杂的防火墙规则和错综复杂的服务质量配置。这就是适合您的设备。将原始电源和实用程序与可靠的 10G 网络相结合。是的,就像任何 ISP 级设备一样, 我们已经包含了一个双冗余电源。 因此,您可以少担心一件事。.

Mikrotik CCR2116-12G-4S+ :经过时间考验的技术,面向未来。

Mikrotik RouterBOARD 的操作系统(固件)

它还可以安装在 PC 上,并将其变成具有所有必要功能的路由器 — 路由、防火墙、带宽管理、无线接入点、回程链路、热点网关、VPN 服务器等。

防火墙和路由器
  • 状态包检测 (SPI)
  • GeoIP 阻止
  • 反欺骗
  • 基于时间的规则、连接规则
  • 动态 DNS、反向代理
  • 强制门户访客网络
  • 支持并发 IPv4 和 IPv6
  • NAT 映射(入站/出站)
  • VLAN 支持 (802.1q)
  • 可配置的静态路由
  • IPv6 网络前缀转换
  • IPv6 路由器广告
  • 每个接口有多个 IP 地址
  • DHCP 服务器、DNS 转发
  • 局域网唤醒、PPPoE 服务器
VPN
  • IPsec 和 OpenVPN
  • 站点到站点和远程访问 VPN 支持
  • SSL 加密
  • 适用于多种操作系统的 VPN 客户端
  • 适用于移动设备的 L2TP/IPsec
  • 用于故障转移的多 WAN
  • IPv6 支持
  • 拆分隧道
  • 多条隧道
  • VPN 隧道故障转移
  • NAT 支持
  • 自动或自定义路由
  • 本地用户身份验证或 RADIUS/LDAP
入侵防御系统
  • 基于 Snort 的数据包分析器
  • 第 7 层应用检测
  • 多个规则来源和类别
  • 新兴威胁数据库
  • IP 黑名单数据库
  • 预设规则配置文件
  • 按接口配置
  • 抑制误报警报
  • 深度数据包检测 (DPI)
  • 用于阻止应用程序的可选开源包

 

 

企业可靠性
  • 可选的多节点高可用性集群
  • 多 WAN 负载平衡
  • 自动连接故障转移
  • 带宽限制
  • 流量调整向导
  • 根据流量优先级预留或限制带宽
  • 公平共享带宽
  • 用户数据传输配额
用户认证
  • 本地用户和组数据库
  • 基于用户和组的权限
  • 可选的帐户自动到期
  • 外部 RADIUS 身份验证
  • 重复尝试后自动锁定
代理和内容过滤
  • HTTP 和 HTTPS 代理
  • 非透明或透明缓存代理
  • 域/URL 过滤
  • 防病毒过滤
  • 搜索引擎的安全搜索
  • HTTPS URL 和内容筛选
  • 网站访问报告
  • 域名黑名单 (DNSBL)
  • 每日、每月等的使用情况报告。

常规性能翻倍:我们从 MikroTik 用户会议中收集您的反馈,打造完美的家庭实验室路由器:紧凑、强大、具有多种供电选项和高效冷却。RB5009 拥有一切,甚至更多!

该板具有 9 个有线端口和一个全尺寸 USB 3.0。 其中七个端口是千兆以太网,另一个是 2.5 千兆以太网,最后一个是 10G SFP+ 笼。 所有端口都连接到功能强大的 Marvell Amethyst 系列交换芯片,该交换芯片具有 10 Gbps 全双工线路,通向 Marvell Armada 四核 ARMv8 1.4 GHz CPU。 CPU 和开关芯片都位于电路板的底部——因此机箱充当了一个巨大的散热器!

主板配备 1GB DDR4 RAM 和 1GB NAND 存储。 与我们其他外形相似的产品相比,这种端口和组件的组合在 CPU 负载较重的配置中提供了几乎两倍的性能。

使用一套简单的安装配件,您可以在一个 1U 机架安装空间中安装四个这样的路由器! 不再有服务器机房俄罗斯方块,只有纯粹的生产力。

管理员

配置
  • 基于网络的配置
  • 用于初始配置的设置向导
  • 基于 Web 的远程管理
  • 可自定义的仪表板
  • 轻松的配置备份/恢复
  • 配置导出/导入
  • 加密自动备份到 Netgate 服务器
  • 可变级别的管理权限
  • 多语言支持,简单更新
  • 向前兼容的配置
  • 用于外壳访问和恢复选项的串行控制台
系统安全
  • Web 界面安全保护
  • CSRF 保护
  • HTTP 引用执行
  • DNS 重新绑定保护
  • HTTP 严格传输安全
  • 框架保护
  • 可选的基于密钥的 SSH 访问
  • 默认阻止 WAN 的专用网络
  • 默认阻止 bogon 网络
  • L2TP VPN、OpenVPN、IPsec
  • 默认阻止 bogon 网络
453 / 5,000 翻译结果
报告 & 监控
  • 带有可配置小部件的仪表板
  • 本地日志记录
  • 远程记录
  • 本地监控图表
  • 实时接口流量图
  • SNMP 监控
  • 通过网络界面、SMTP 或 Growl 通知
  • 硬件监控
  • 网络诊断工具
  • BandwidthD、MRTG 类流量图

 

 

MikroTik.Пакеты RouterOS — Часто задаваемые вопросы по CloudHosting

МикроТик. Пакеты RouterOS

RouterOS поставляется со специальным набором пакетов, обеспечивающих основные функции. Поскольку эта операционная система достаточно универсальна, существует множество пакетов, расширяющих функциональность этой сетевой системы. Пакеты поставляются только Mikrotik и не могут поставляться сторонними разработчиками. Для того, чтобы подключить пакет, его нужно скачать с официальной страницы, разархивировать и закинуть в корень роутера.После перезагрузки этот пакет будет установлен.

Доступность пакета зависит от платформы (mipsle, mipsbe, ppc, x86). Основной пакет system package, его нельзя удалить, он стоит по умолчанию на всех роутерах. Кроме него из коробки, в поставку для устройства Mikrotik входит достаточно большое количество упаковок. В этот пакет входят DHCP, ppp и другие. Стоит помнить, что эти пакеты являются необязательными и могут быть отключены или удалены с маршрутизатора.

Пакеты можно устанавливать в раздел /system package

Для домашнего или офисного роутера достаточно оставить минимальное количество пакетов для экономии ресурсов роутера. Это advanced-tools — пакет сетевой диагностики, dhcp — DHCP-сервер и клиентский пакет, ppp — VPN-сервер и клиент, security — безопасное подключение к WinBox, system — пакет по умолчанию, wireless — пакет поддержки беспроводной сети.

Чтобы отключить пакет, вам нужно выбрать его и нажать кнопку Отключить — это запланирует отключение пакета при следующей перезагрузке устройства.Если вы нажмете кнопку Uninstall , пакет будет удален во время перезагрузки. Кнопка Unschedule — удалит запланированное задание для выбранного пакета.

Список пакетов

расширенные инструменты (mipsle, mipsbe, ppc, x86) инструменты проверки связи. netwatch, ip-сканирование, смс-инструмент, пробуждение по локальной сети

calea (mipsle, mipsbe, ppc, x86) Пакет, обеспечивающий возможность перехвата и регистрации сетевого трафика с использованием правил брандмауэра, а также может выступать в роли сервера хранения.В октябре 1994 года Конгресс США принял дополнительные меры для защиты общественной и национальной безопасности, утвердив положения Закона о помощи правоохранительным органам в области связи (CALEA) Закона об охране правопорядка в области телекоммуникаций. Одной из основных задач CALEA было формирование такой системы взаимодействия спецслужб и операторов, при которой правоохранительным органам не нужно было бы иметь своих специалистов по каждой технологии связи, а была бы возможность получать от службы поставщиков готовой, интересной, в плане проведения оперативно-розыскных мероприятий, информации.

dhcp (mipsle, mipsbe, ppc, x86) Протокол динамического управления хостом. Включает возможность использования DHCP-сервера и DHCP-клиента.

GPS (mipsle, mipsbe, ppc, x86) Поддержка GPS (глобальная система позиционирования). Пакет необходим при подключении внешнего модуля GPS.

точка доступа (mipsle, mipsbe, ppc, x86) Включает сервер HOTSPOT на маршрутизаторе.

ipv6 (mipsle, mipsbe, ppc, x86) Поддержка протокола IPv6.

mpls (mipsle, mipsbe, ppc, x86) Включение поддержки MPLS (Multi Protocol Labels Switching). Механизм в высокопроизводительной телекоммуникационной сети, передающий данные от одного узла сети к другому с помощью тегов.

многоадресная рассылка (mipsle, mipsbe, ppc, x86) Поддержка многоадресной рассылки включена.

ntp (mipsle, mipsbe, ppc, x86) Включает NTP-сервер и клиент в маршрутизаторе. Стоит сказать, что SNTP-клиент уже включен в системный пакет, и если вам не нужен NTP-сервер, то нет смысла его устанавливать.

openflow (mipsle, mipsbe, ppc, x86) Включает поддержку OpenFlow.

ppp (mipsle, mipsbe, ppc, x86) Включает клиент MlPPP, клиенты PPP, PPTP, L2TP, PPPoE, ISDN PPP и сервер.

маршрутизатор (mipsle, mipsbe, ppc, x86) Доступ и управление RouterBOOT. Информация о RouterBOARD.

маршрутизация (mipsle, mipsbe, ppc, x86) Включает поддержку протоколов динамической маршрутизации RIP, BGP, OSPF, а также BFD и фильтров маршрутов.

безопасность (mipsle, mipsbe, ppc, x86) Включает поддержку IPSEC, SSH и Secure WinBox

система (mipsle, mipsbe, ppc, x86) Базовый пакет, включающий статическую маршрутизацию, IP-адреса, sNTP, telnet, API, очереди, брандмауэр, веб-прокси, кэш DNS, TFTP, пул IP-адресов, SNMP, анализатор пакетов , средство отправки электронной почты, построение графиков, тест пропускной способности, факел, EoIP, IPIP, мост, VLAN, VRRP. Дополнительно — MetaROUTER, Виртуализация.

UPS (mipsle, mipsbe, ppc, x86) Включает интерфейс управления ИБП APC.

user-manager (mipsle, mipsbe, ppc, x86) MikroTik User Manager — биллинг от Mikrotik.

wireless (mipsle, mipsbe, ppc, x86) Пакет, обеспечивающий беспроводной интерфейс в микротике.

arlan (x86) Поддержка Aironet Arlan — устаревшей беспроводной технологии.

isdn (x86) Поддержка модема ISDN.

lcd (x86) Поддержка ЖК-панелей сторонних производителей, которые подключаются через последовательный/параллельный порт.Пакет не требуется для встроенных сенсорных панелей в RouterBoard.

radiolan (x86) Включает поддержку карт RadioLan.

синхронный (x86) Поддержка FarSync. Служил для тиражирования.

xen (снята с производства x86) XEN Virtualization — включить виртуализацию.

kvm (x86) KVM Virtualization — включить виртуализацию.

tr-069 (mipsle, mipsbe, ppc, x86) Технический отчет 069 — CPE WAN Management Protocol (CWMP) для удаленного управления устройствами.

routeros-mipsle (mipsle) Пакет для платформы mipsle (RB100, RB500). По умолчанию включает систему, точку доступа, беспроводную связь, ppp, безопасность, mpls, дополнительные инструменты, dhcp, маршрутизатор, ipv6, маршрутизацию.

routeros-mipsbe (mipsbe) Пакет для платформы mipsbe (RB400). По умолчанию включает систему, точку доступа, беспроводную связь, ppp, безопасность, mpls, дополнительные инструменты, dhcp, маршрутизатор, ipv6, маршрутизацию.

routeros-powerpc (ppc) Пакет Powerpc (RB300, RB600, RB1000).По умолчанию включает систему, точку доступа, беспроводную связь, ppp, безопасность, mpls, дополнительные инструменты, dhcp, маршрутизатор, ipv6, маршрутизацию.

routeros-x86 (x86) Пакет для платформ x86 (Intel/AMD PC, RB230). По умолчанию включает систему, точку доступа, беспроводную связь, ppp, безопасность, mpls, дополнительные инструменты, dhcp, маршрутизатор, ipv6, маршрутизацию.

МикроТик RB44Ge | CloudRouterSwitches.com

Продукты MikroTik

Интерфейсы MikroTik

MikroTik RB44Ge IEEE 802.3x Четыре порта Gigabit Ethernet PCI Express

#RB44Ge
Узнать цену!

Совершенно новая карта Gigabit Ethernet имеет четыре порта Gigabit Ethernet 10/100/1000T на одной плате, что дает вам возможность добавить еще больше портов на маршрутизатор и сэкономить ценные слоты PCIe. Обеспечьте своему устройству максимальную пропускную способность и плотность портов, а с PCIe скорость шины больше не является пределом.

Карта использует высокопроизводительный чип Atheros AR8131/M:

  • Функции разгрузки контрольной суммы для IP, TCP и UDP, снижающие нагрузку на ЦП и оптимизирующие производительность сети
  • Wake-On-LAN (WOL) и AMD Magic PacketTM.
  • Поддержка управления потоком, совместимого с IEEE 802.3x
  • Объединение прерываний
  • Усовершенствованная архитектура DSP, реализующая цифровую адаптивную коррекцию, подавление эха и перекрестных помех
  • Диагностический тест кабеля (CDT) для обнаружения обрыва, короткого замыкания, длины кабеля и неправильного или несоответствующего импеданса.
  • Интеллектуальное снижение мощности в зависимости от обнаруженной длины кабеля
  • Поддержка функции Green Ethernet
  • Поддерживает Energy Star 4.0
Технические характеристики RB44Ge
Набор микросхем Атерос AR8131M
Формат PCIe 4X
Ethernet Четыре независимых порта Gigabit Ethernet 10/100/1000 Мбит с Auto-MDI/X
Размеры 150 мм x 69 мм (без кронштейна)
Операционная система RouterOS, Windows, Linux

Загрузите спецификацию MikroTik RB44Ge (PDF).

Leave a comment